php5.6版本iconv_set_encoding函数报错Deprecated

PHP5.6版本之后不赞成使用iconv_set_encoding函数,如果使用该函数就会出现“Deprecated: iconv_set_encoding(): Use of iconv.internal_encoding is deprecated in ...”相关的提示,可以使用下面的代码来避免这个问题:

if (PHP_VERSION_ID < 50600) {  
    iconv_set_encoding('input_encoding', 'UTF-8');  
    iconv_set_encoding('output_encoding', 'UTF-8');  
    iconv_set_encoding('internal_encoding', 'UTF-8');  
} else {  
    ini_set('default_charset', 'UTF-8');  
}  

代码用意是当php版本小于5.6时就使用该函数,否则不使用。

关键词: php

网友留言(0条)

发表评论