展开菜单

js判断IE版本,禁止低版本IE浏览器代码

对于大多数程序员和美工设计人员来说,ie6,7漏洞颇多 ,兼容性问题不断,今天我们就来写一段javascript代码强制用户升级到IE高版本: var Sys = {}; var ua = navigator.userAgent.toLowerCase(); if (window.ActiveXObject){ Sys.ie = ua.match(/msie ([\d.]+)/)[1]; if (Sys.ie<=7){ alert('你目前的IE版本为'+Sys.ie+'版本太低,请升级!'); location.href="http://wind...

去掉IE6下超链接图片默认蓝色边框border问题

使用HTML+div+css制作网页时,如果网页中的图片使用了超链接,IE6浏览器就会显示蓝色边框,可以通过css代码去掉该超链接图片的边框效果。 img {border:0;}

在IE6中使用了float浮动元素导致margin产生双边距的解决方法

使用CSS+DIV制作网页的时候,由于目前浏览器太多,每个浏览器都有不同的CSS的BUG问题,其中IE浏览器特别多,加上用户总坚持着老版本不放,也加重了网页设计师的麻烦。float浮动之后margin产生双边距便是IE6中很明显的BUG。 什么是双边距? 先看以下CSS代码: #neirong{float:left;width:250px;height:250px;margin:10px;} 表示宽高为250像素的DIV左浮动,上右下左的边距margin为10像素。在其它浏览器中会如实显示,但在IE6中,左边距会变成20像素。这便是双边距。 产生的条件。 对于I...

兼容IE6浏览器的jQuery实现边栏随滚动条固定

侧边栏随滚动条上下滚动,始终固定在一个位置的功能,现在很多网站和博客都有这个功能,部分购物网站用这个功能放购物车或商品分类导航,使产品页面很长的时候,侧边栏能始终固定发挥它应有的作用,有的网站用这个功能来边栏的广告。 jQuery代码: var rollSet = $('#Roll');// 检查对象,#sidebar-tab是要随滚动条固定的ID,可根据需要更改 var offset = rollSet.offset(); $(window).scroll(function () { // 检查对象的顶部是否在游览器可见的范围内 var scrollT...

解决IE6/IE7下绝对定位position:absolute和margin的冲突问题

解决IE6/IE7下绝对定位position:absolute和margin的冲突问题

绝对定位(position:absolute;)的相邻元素margin-top失效,但如果相邻元素(layer3)去掉width属性,margin-top又会生效,首先我们来看一个代码: <div id="layer1″ style=”margin:20px; border:1px solid #F88; width:400px;"> <div id="layer2" style="position:absolute; background-color:#ccc;"> Absolute (layer2) </div> &...

hover在IE6下的问题及解决方法

在处理CSS的机制上,拿对伪类:hover的支持来说,IE7+添加了对a以外其它标签的支持,但在IE6下:hover就连对a的支持都不是那么的尽如人意。有的时候为了增加一些简单的动态效果,常常会借助:hover的帮忙,比如我们时常会令鼠标经过链接时改变文字的颜色。 如: a:hover{color:#F00;} <a href ="#">鼠标经过时改变我的颜色</a> 在所有的浏览器中都生效。如果换成这样: a:hover em{color:#F00;} ...

GoogleCode项目JavaScript巧解IE6与IE8兼容性问题

由于目前IE6.0还是使用人比较多的浏览器(国内盗版猖獗),我们可以用一段JS调用解决IE6-IE8的兼容性问题,这是调用的一个在GoogleCode上的项目,速度快又不占用您的带宽。 如果是IE7 <!--[if lt IE7]> <scriptsrcscriptsrc=”http://ie7-js.googlecode.com/svn/version/2.0(beta3)/IE7.js”type=”text/javascript”></script> <![endif]--> 如...

网页制作css技巧之zoom:1;作用

zoom这个特性是IE特有的属性。 zoom:1;一般是拿来解决IE6的子元素浮动时候父元素不随着自动扩大的问题,功能相当于overflow:auto,同样也可以用height:1%来代替zoom:1。 所以一般要在浮动元素的父元素加上overflow:auto;zoom:1; 。这样,子元素浮动,父元素再也不会不自动跟子元素扩大了。 PS:一直认为IE6应该从广大网民的电脑中删除或升级了,作为网页制作者,应该不再去为IE6、IE7这样的极品费脑筋,直接不兼容,让IE6用户不得不升级!

调用html5.js实现IE(包括IE6)支持HTML5元素

微软的最新浏览器IE8及以下IE版本对HTML5标签的支持是有限的,我们可以通过在网页中添加脚本的方式来解决目前IE浏览器对HTML5支持的问题。 让IE(包括IE6)支持HTML5元素,我们需要在HTML头部添加以下JavaScript,这是一个简单的document.createElement_x声明,利用条件注释针对IE来调用这个js文件。Opera,FireFox等其他非IE浏览器就会忽视这段代码,也不会存在http请求。 <!–[if IE]> <script src=”http://html5shiv.googlecode.com/svn/tru...

IE6不支持min-height的解决办法

IE6不支持min-height的解决办法有两种解决方案。 方法一:利用IE6不识别!important来实现 height:auto!important; height:500px; min-height:500px; 方法二:必须保证#test以外的都要是overflow:visible。否则还是不会显示超出。 min-height:100px; background:#BBB; _height:100px; overflow: visible;

完美解决IE6不支持position:fixed的bug

先看下面一段代码: <!DOCTYPE html> <html> <head> <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> <title>IE6 position:fixed bug</title> <style> *{padding:0;margin:0} p{height:2000px} #gs{border:1px solid #000;position:fixed;r...